ANPR and OpenALPR integration

Xeoma Software

Moderators: Admin_N, Admin_K, Administrator, Admin_P

ANPR and OpenALPR integration

Postby XeoMax » Thu Nov 15, 2018 3:14 pm

Hello.
I bought a PRO license for the anpr module.
I'm in Italy, so i downloaded via GUI the openalpr module and selected "Europe and UK".
It doesn't recognize nothing.
If i tick the "Russia" checkbox, it recognizes the plates but all plate numbers are wrong (obvioulsy).
Can someone point me in the right direction, on how to get the "Europe and UK" recognition to work?
Thanks.
XeoMax
 
Posts: 43
Joined: Fri Apr 08, 2016 2:59 pm

Re: ANPR and OpenALPR integration

Postby Admin_N » Tue Nov 20, 2018 10:08 am

Hello,

What version of Xeoma do you use, on what operating system?

The failure to detect your license plates might be connected with how the license plates are positioned (the angle might be too acute, the image might be too blurry, the lighting might be too poor, etc.)
We recommend you to try different combinations of the listed parameters.
Also, we could send you recommendations if you send us a screenshot of how the license plates are positioned in camera image to our support.

You can't really use the "Russia" checkbox for comparison because it doesn't use openALPR. Instead, techniques developed by our team are used for recognition of Russian and Kazakhstanian license plates. So they have different algorithms for detection of license plates and can't be compared.

BR,
Admin_N
Admin_N
 
Posts: 740
Joined: Thu Mar 01, 2012 4:43 pm

Re: ANPR and OpenALPR integration

Postby XeoMax » Tue Nov 20, 2018 10:25 am

Hello
Xeoma 18.11.14 running on a MAC Mini with MacOs Mojave
I'm testing the stuffs in the laboratory. Tested with the plate in any angle. Tried to adjust some options in the Xeoma GUI but nothing changes. I see that Xeoma takes a shot and saves it in the Openalpr folder, but then nothing happens.

Xeoma_1_.png
Xeoma_1_.png (158.72 KiB) Viewed 9555 times

Xeoma_18_11_14__Pro_version__Real_time_view.png
Xeoma_18_11_14__Pro_version__Real_time_view.png (113.2 KiB) Viewed 9555 times
XeoMax
 
Posts: 43
Joined: Fri Apr 08, 2016 2:59 pm

Re: ANPR and OpenALPR integration

Postby Admin_N » Tue Nov 20, 2018 3:23 pm

If it's not a real vehicle with a real plate, just a number for tests instead, you should untick the "Recognize only changed areas" option at the bottom of your ANPR module settings. You can find the option under the monitored zone section, where you should also make sure that the sufficient area is marked with the red brush.

Does it help?
Admin_N
 
Posts: 740
Joined: Thu Mar 01, 2012 4:43 pm

Re: ANPR and OpenALPR integration

Postby XeoMax » Tue Nov 20, 2018 4:19 pm

Hello Admin
Thanks for the suggestion but unfortunately, nothing changes.
Tried with these cars with checkbox and without checkbox. Does it work for you? I suspect a problem in lauching the openalpr program. Maybe due to permission or so.
fiat-panda-natural-power-auto-a-metano.jpg
fiat-panda-natural-power-auto-a-metano.jpg (62.13 KiB) Viewed 9550 times

98970885917629.jpg
98970885917629.jpg (38.26 KiB) Viewed 9550 times
XeoMax
 
Posts: 43
Joined: Fri Apr 08, 2016 2:59 pm

Re: ANPR and OpenALPR integration

Postby Admin_N » Wed Nov 21, 2018 1:46 pm

Yep, both work ok.
rec_num.jpg
rec_num.jpg (215.19 KiB) Viewed 9525 times

rec_num2.jpg
rec_num2.jpg (230.02 KiB) Viewed 9525 times

Might be the permissions but also might be wrong settings.

Here's what you should check:
*TICK Europe and EU, nothing else
*UNTICK Russia and Kazakhstan
*SET "Postrecord" to 3 secs
*SET "Detection type" to DETECT ALWAYS
*SET "Show information" for 3 secs
*Make sure the red zone covers the license plate
*UNTICK "Recognize only changed areas"
*Make sure there is nothing in the white list and in the path for external utility
*Make sure that the ANPR is connected to the Preview and Archive module without any other filters

Does it help? If not, well, maybe it is the permissions - could you look into your Mac's settings for the openalpr launch?
Admin_N
 
Posts: 740
Joined: Thu Mar 01, 2012 4:43 pm

Re: ANPR and OpenALPR integration

Postby XeoMax » Wed Nov 21, 2018 2:49 pm

Nothing.
I highly suspect, that MacOS isn't compatible with the precompiled OpenAlpr program.
I've tried to download OpenAlpr on a Debian machine and started "alpr" by hand. The above images have been correctly detected.
For now, i've workarouded that by using a node-red flow on that Debian machine, but it would be nice if OpenAlpr had work in the Xeoma program as well.
If you've time to spend, i suggest you to try to install Xeoma on a Mac and give it a try. :-)
XeoMax
 
Posts: 43
Joined: Fri Apr 08, 2016 2:59 pm

Re: ANPR and OpenALPR integration

Postby Admin_N » Thu Nov 22, 2018 12:24 pm

Thanks for your feedback.

openALPR works on Mac OS, too (including when used from Xeoma). And Xeoma (and openALPR) works under Debian as well.

That all said, you might want to re-install Xeoma and openALPR on your Mac, or look into your Mac OS permissions.
Admin_N
 
Posts: 740
Joined: Thu Mar 01, 2012 4:43 pm

Re: ANPR and OpenALPR integration

Postby XeoMax » Fri Nov 23, 2018 12:41 pm

Hello Admin.
Running alpr manually on the Mac, from the xeoma's openalpr path, do works.
Running it from xeoma, doesn't.
I must give up :(
Thank you anyway.
XeoMax
 
Posts: 43
Joined: Fri Apr 08, 2016 2:59 pm

Re: ANPR and OpenALPR integration

Postby Admin_K » Fri Nov 15, 2019 3:06 pm

XeoMax Wrote:Hello Admin.
Running alpr manually on the Mac, from the xeoma's openalpr path, do works.
Running it from xeoma, doesn't.
I must give up :(
Thank you anyway.


Hi, we're sorry to hear that it still doesn't work.

Anyway, feel free to contact us anytime via Skype, online chat or email, we'll gladly and quickly help!
Admin_K
 
Posts: 322
Joined: Tue Apr 07, 2015 2:20 pm

Re: ANPR and OpenALPR integration

Postby XeoMax » Fri Nov 15, 2019 3:30 pm

Thank you, but i suspect something in macOS interfere wit it. Never mind. Thank you.
XeoMax
 
Posts: 43
Joined: Fri Apr 08, 2016 2:59 pm

Re: ANPR and OpenALPR integration

Postby CoddyG » Mon May 10, 2021 12:19 pm

Voglio che tu mi aiuti a risolvere anche questo problema.
CoddyG
 
Posts: 4
Joined: Sat May 08, 2021 6:08 pm

Re: ANPR and OpenALPR integration

Postby admin_mary » Thu May 13, 2021 11:24 am

[quote="CoddyG"]Voglio che tu mi aiuti a risolvere anche questo problema.[/quote]
Could you please tell us which version of Xeoma are you using? Try to update to the latest version 21.4.2
You can download it by the link: ([url]https://felenasoft.com/xeoma/en/download/[/url])
admin_mary
 
Posts: 14
Joined: Wed Mar 10, 2021 8:18 am


Return to Xeoma - General discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron