hardware acceleration for nvidia gpu

Xeoma Software

Moderators: Admin_N, Admin_K, Administrator, Admin_P

hardware acceleration for nvidia gpu

Postby adamf663 » Fri Jan 25, 2019 5:33 pm

I have been unable to get hardware acceleration working.
My video card is new and supports cuda: MSI nVidia GeForce GT440 1GB DDR3 VGA/DVI/HDMI Low Profile PCI-Express Video Card N440GT-MD1GD3/LP .

Xeoma version:
18.11.21

uname -a:
Linux desktop 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

nvidia-smi:
Fri Jan 25 10:30:25 2019
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 415.27 Driver Version: 415.27 CUDA Version: 10.0 |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GT 1030 Off | 00000000:01:00.0 On | N/A |
| N/A 45C P8 N/A / 30W | 107MiB / 1998MiB | 6% Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1757 G /usr/lib/xorg/Xorg 53MiB |
| 0 1990 G /usr/bin/sddm-greeter 42MiB |
+-----------------------------------------------------------------------------+
adamf663
 
Posts: 3
Joined: Fri Jan 25, 2019 5:24 pm

Re: hardware acceleration for nvidia gpu

Postby adamf663 » Tue Jan 29, 2019 3:50 pm

Has nobody ever seen hardware acceleration work?
adamf663
 
Posts: 3
Joined: Fri Jan 25, 2019 5:24 pm

Re: hardware acceleration for nvidia gpu

Postby Admin_P » Fri Feb 01, 2019 9:19 am

Hello! I'm afraid you won't be able to use this model for hardware acceleration under Linux, since it does not fit the minimal requirements.
While the card does support CUDA and it is technically possible to use for decoding, the load balancing makes it rather ineffective. The difference in CPU load would be neglectably small.
Admin_P
 
Posts: 228
Joined: Wed Aug 24, 2016 1:49 pm

Re: hardware acceleration for nvidia gpu

Postby adamf663 » Fri Feb 01, 2019 1:11 pm

I think that minimal requirements link was incorrect. It points me to a page I've already seen with a 'hardware acceleration' topic that isn't a link.
The sum total requirements mentioned are:

the preview stream (the first URL in the module) needs to be of at least HD quality (720p or 1280×720) – otherwise, acceleration is counter-productive;
the GPU itself should be at least Nvidia GeForce 400 series or higher (for Linux: GeForce GTX 750, GTX 900 or higher).

An ASUS GeForce GT 1030 doesn't qualify? (I think I reported incorrectly the video card although nvidia-smi reported it correctly._)
adamf663
 
Posts: 3
Joined: Fri Jan 25, 2019 5:24 pm

Re: hardware acceleration for nvidia gpu

Postby jimmydean22456 » Thu Feb 11, 2021 3:23 pm

I'm having the same problem, my Xeoma is running in Linux as well with a GTX 960 available and even though I believe I've met the criteria of having HD preview stream it is still not using hardware acceleration.

nvidia-smi Output:
# nvidia-smi
Thu Feb 11 15:17:34 2021
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 455.38 Driver Version: 455.38 CUDA Version: 11.1 |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 960 Off | 00000000:31:00.0 Off | N/A |
| 0% 40C P8 13W / 128W | 3MiB / 4043MiB | 0% Default |
| | | N/A |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| No running processes found |
+-----------------------------------------------------------------------------+

Camera settings photo attached
Attachments
Xeoma Camera Settings.png
Xeoma Camera Settings.png (162.65 KiB) Viewed 4454 times
jimmydean22456
 
Posts: 1
Joined: Thu Feb 11, 2021 3:16 pm

Re: hardware acceleration for nvidia gpu

Postby Admin_P » Fri Feb 19, 2021 1:31 pm

Hello!
This has been fixed quite recently, you may want to send us an e-mail ([url]https://felenasoft.com/xeoma/en/contacts/[/url]) requesting the newest beta or wait for the official release.
Admin_P
 
Posts: 228
Joined: Wed Aug 24, 2016 1:49 pm

Re: hardware acceleration for nvidia gpu

Postby Flole » Thu May 06, 2021 2:20 pm

Aaaand it's broken again in the latest release.... :(
Flole
 
Posts: 9
Joined: Thu Aug 16, 2018 5:44 pm


Return to Xeoma - General discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron