RESOLVED I guess....wrong password on (new) client

Xeoma Software

Moderators: Admin_N, Administrator, Admin_P, Admin_K

RESOLVED I guess....wrong password on (new) client

Postby ltgcc » Thu Feb 10, 2022 8:27 pm

RESOLVED I guess....I started things up to get a 'latest and greatest' screencap of the client...and it seems to be working as expected now. I have no idea....

thank you anyway. :D

EDIT: I just noticed I pasted the screenshot that still has the password *'ed out. When I get a moment I'll paste the one that shows the password as 'password' but it will be later this evening. I apologise for being clumsy here.

Good morning. I hope the day finds everyone well.

I am installing a new xeoma version 21.11.18 on a debian 11 box.

I am getting a 'wrong password' error on xeoma client when I try to log in.

Description:

everytihng on the server is run as 'root'

root@xeoma:~# uname -an
Linux xeoma 5.13.19-4-pve #1 SMP PVE 5.13.19-9 (Mon, 07 Feb 2022 11:01:14 +0100) x86_64 GNU/Linux
root@xeoma:~#


root@xeoma:/home/xeoma# ./xeoma.app -install -hiddenmode -installdir /opt/xeoma -programdir /opt/xeoma/bin -startdelay 10 -log
install hidden mode ...
* Ok > Install::installExeFiles
* Ok > Install::installResourceFiles
* Ok > Install::installFiles
* Ok > Install::runInstallFiles
* Ok > Install::popClientFromAutorun
* Ok > Install::uninstallCloudShortcut
* Ok > Install::uninstallCloudServer
* Ok > Install::uninstallLicenseServerShortcut
* Ok > Install::uninstallLicenseServer
* Ok > Install::unInstallCoreShortcut
* Ok > Install::unInstallClientShortcut
* Ok > Install::uninstallCloudShortcut
* Ok > Install::unRegisterInSystem
---------- Install::runWithAdminRights ----------
* Ok > Install::stopCore
* Ok > Install::registerCoreAsService
* Ok > Install::exchangeOldExeFileToNew
* Ok > Install::moveFilesToNewLocation
* Ok > Install::createLinkFileToNewLocation
* Ok > Install::installUserFiles
------------------------------------
* Ok > Install::runWithAdminRights
* Ok > Install::removeOldExe
* Ok > Install::installHiddenMode

Settings path: /opt/xeoma
Executable file's path: /root/bin/Xeoma/xeoma

Ok


Current password for network access: RD5sUC/sE5


root@xeoma:/home/xeoma# /root/bin/Xeoma/xeoma -setpassword password


Password set successfull
root@xeoma:/home/xeoma# /root/bin/Xeoma/xeoma -showpassword


Current password for network access: password


On client side:

~/xeoma $ ./xeoma -client password@192.168.42.17:8090 <--192.168.42.17 is the box with xeoma server described above.

Screenshot of client with 'wrong password' attached (hopefully).

no firewalls or impediments. tcp access to port 8090 verified:

michelle ~ $ telnet 192.168.42.17 8090
Trying 192.168.42.17...
Connected to 192.168.42.17.
Escape character is '^]'.

What next?

Thanks,
Attachments
xeoma-wrong-password-Screenshot at 2022-02-10 11-17-16.png
screenshot of xeoma client with 'wrong password' error
xeoma-wrong-password-Screenshot at 2022-02-10 11-17-16.png (42.21 KiB) Viewed 7940 times
ltgcc
 
Posts: 6
Joined: Wed Aug 12, 2020 4:56 pm

Re: RESOLVED I guess....wrong password on (new) client

Postby Admin_P » Thu Jun 23, 2022 8:22 am

Hi! Even though the issue is resolved, I'll post a few details here, in case anyone runs into something similar.
When you are changing the Admin's password (as opposed to just a user's password) for a server where Xeoma runs as a service (be it Linux, Mac or Windows), you need to restart the service for that change to fully take effect.
Alternatively, you can apply the new password first, and them install Xeoma as a service.
Admin_P
 
Posts: 245
Joined: Wed Aug 24, 2016 1:49 pm


Return to Xeoma - General discussion

Who is online

Users browsing this forum: No registered users and 7 guests

cron