Older Versions Won't Run On NUC

Xeoma Software

Moderators: Admin_N, Administrator, Admin_P, Admin_K

Older Versions Won't Run On NUC

Postby rcrawford » Tue Sep 26, 2023 2:26 pm

I have a NUC that has an Intel i5 CPU, 16 GB of RAM, and 256 GB SSD that is running the latest version of Linux Mint.

Using the web browser on the NUC I can visit the "www.felenasoft.com/xeoma/en/download" website and click its <Download> button for Xeoma 23.8.10 for Linux 64-bit to download a file named "xeoma_linux64.tgz". After the download is complete, I can extract the "xeoma.app" file from this .tgz file. Afterwards, when I double-click on the "xeoma.app" file, its application launches successfully.

Using the same web browser on the same NUC I can visit the "www.felenasoft.com/xeoma/en/changes/" website and click its <Download> button for Xeoma 20.12.18 for Linux 64bit (because my Xeoma license is for V20) to download a file that is also named "xeoma_linux64.tgz". After the download is complete, I can extract the "xeoma.app" file from this .tgz file as well. However, whenever I double-click on the "xeoma.app" file that comes from this .tgz file, nothing happens! I have tried repeating this procedure for other Xeoma 20.x versions, but all of their "xeoma.app" files do the same thing (i.e. nothing).

I want to move my Xeoma v20.4.3 server from my PC (which runs the exact same version of Linux Mint and the exact same version of web browser) to this NUC, but this issue is preventing me from doing so. Oddly, I can perform the steps mentioned above on the PC, and the "xeoma.app" files for both versions run properly. Summarizing, it seems that the Linux Mint 21.2 recognizes the v23.8.10 "xeoma.app" file as an executable file but not the "v20.12.18" version. Because I don't understand how Linux is supposed to know how to launch the "xeoma.app" files, I have not found a way to generate any kind of error message or log to troubleshoot the problem.

FYI, I tried opening a Terminal window, navigating to the same directory that the v20.12.18 "xeoma.app" file was in, and then executing the command "./xeoma.app -install -coreauto". This created a "Xeoma" launcher on the Desktop, but double-clicking (or right-clicking it and then selecting "Open") doesn't do anything.
rcrawford
 
Posts: 1
Joined: Tue Sep 26, 2023 1:53 pm

Re: Older Versions Won't Run On NUC

Postby Admin_N » Mon Nov 27, 2023 2:56 pm

May I suggest reinstalling your Xeoma on the NUC and starting anew? This might reveal what went wrong the previous time.
Here are instructions on how to do that - first, through console/Terminal (recommended because it displays errors when you come across some) and below we explain how to do the same through Xeoma interface.

I. Through Console:
1) Remove the program. Execute
[PATH_TO_XEOMA]/xeoma.app -install -removeexe
Tip: The -removeexe command will preserve recordings and settings, but if you don't want to keep those files you can replace it with -removeall instead.

2) Download the 2020 version [from our website](https://felenasoft.com/xeoma/en/changes/). It is extremely important that you choose the one that suits your OS! You can use the wget command.
For example if you are sure your NUC is running under one of Linux 64-bit OSes:
https://felenasoft.com/xeoma/downloads/ ... inux64.tgz

3) Unpack the archive with tar -xvzf
For example:
tar -xvzf xeoma_linux64.tgz (if your NUC is running under a Linux 64-bit OS)
Tip: this step is not required for Windows versions of Xeoma for they come as executable files, not archives

4) After unpacking is done, you will get a Xeoma executable file.
For Linux OSes, it's a xeoma.app file.

You can do several things with the app file.

a) You can simply run it manually (both server and client parts at once):
[PATH_TO_XEOMA.app]
and hit OK
b) You can install Xeoma to start with the system:
sudo [PATH_TO_XEOMA] -install -coreauto
- to install only the Server part to autostart while the Client part would need to be started manually;
c) If you went with the b) you can later on launch the Client part only with
[PATH_TO_XEOMA] -client

When you access the file, the short help will be displayed with [commands](https://felenasoft.com/xeoma/en/descrip ... e_commands) that can be used.


II. through GUI:
1) Launch Xeoma
2) Stop the previous version of Xeoma: Main menu –> Install –> Uninstall –> Delete (except for archive and settings)
3) Download the 2020 version [from our website](https://felenasoft.com/xeoma/en/changes/). Choose the version that suits your OS.
4) Unpack the archive by double-clicking on it. (not required for Windows)
5) Launch Xeoma by double-clicking its executable file (for example, xeoma.app or xeoma_win64.exe)
6) To install Xeoma as a service, go to the Main menu –> Install –> Install. Admin rights are required for this action. [More information about installation](https://felenasoft.com/xeoma/en/descrip ... stallation).

Hope this works for you!
Admin_N
 
Posts: 795
Joined: Thu Mar 01, 2012 4:43 pm


Return to Xeoma - General discussion

Who is online

Users browsing this forum: No registered users and 20 guests

cron