Мой первый опыт знакомства с Xeoma (много проблем)

Программа Xeoma

Moderators: Admin_N, Admin_K, Administrator, Admin_P

Мой первый опыт знакомства с Xeoma (много проблем)

Postby Maikl » Sun Sep 27, 2020 9:02 am

Здравствуйте. Расскажу про свой первый опыт (к сожалению, пока неудачный) работы с Xeoma.
В настоящий момент у меня работает 5 IP камер. Две по Onvif, и три от XM по протоколу NETIP. Все они подключены к роутеру по Ethernet. Работают они с автономным регистратором XM на довольно мощном чипе Hi3798M.
И всё работает хорошо, кроме двух моментов... Автономный видеорегистратор не поддерживает предзапись. А по детекции движения ориентируется на детекцию движения от IP-камер, которая довольно дубовая в плане чувствительности. Выгрузка записей с потока H265 из регистратора - это какое-то мучение. Каждый раз приходится править заголовок экспортированного файла в текстовом редакторе.

Поэтому решено было обратиться к софтовому решению на базе Xeoma. Для этих целей я собрал новый компьютер на базе 4-ядерного процессора Ryzen 3 Pro 3200GE со встроенным восьмиядерным GPU Vega 8, DDR4 8Gb, NVME SSD (под систему и сервер. под записи - отдельный HDD).
Далее установил на этот компьютер свежайший дистрибутив MX Linux и свежайшую версию Xeoma (пробную версию).

Теперь начну по порядку с какими проблемами столкнулся.
Первая камера: 4-мегапиксельная PTZ куполка Okayvision PTZ-HD54F20X500. Работает в H265 и H264. Поддерживает RTSP и Onvif 2.4.
Xeoma без проблем нашла камеру и подключилась по RTSP-потоку на дополнительный поток 640х480. При этом когда я попытался выводить изображение с основного потока (2592x1944), то неизменно получал чёрный экран без изображения. Очень долго танцевал с бубном возле этой связки и перепробовал много вариантов и в конце-концов выяснил причину. Оказывается основной поток у меня шёл в H265, а дополнительный поток в H264. Как только я переключил режим дополнительного потока на H265, то Xeoma перестала видеть и его. В итоге пришлось вернуться в каменный век и переключить все потоки на H264. После этого Xeoma с камерой заработала нормально.

Вторая камера: 2-мегапиксельная PTZ куполка Besder HX-HD20M200AS на базе модуля Camhi с чипом Hi3516CV200. В ней есть H265, H264, ONVIF, RTSP, RTMP. Xeoma без проблем к ней подключилась и начала писать поток в H265. Однако не смотря на то, что в настройках модуля Xeoma прописано отображать доп.поток 640х352, а записывать основной поток 1920х1080, Xeoma упорно включала на отображение именно основной поток. И никак мне не удалось решить эту проблему.

Третья камера: 2-мегапиксельный модуль XiongMaitech со встроенным моторизованным зумом на чипе Hi3516CV100. Поддерживает только H264, ONVIF, RTSP. Оказался самым беспроблемным в плане подключения. Так как находится в другой подсети - Xeoma его не нашла. Но при указании в поиске точного IP - без проблем подключилась. Но проблема с отображением только основного потока осталась, так же как и с предыдущей камерой. Не смотря на все настройки модуля отображения в программе - Xeoma упорно гонит 2-мегапиксельный основной поток на экран.

Четвёртая камера: 2-мегапиксельный модуль XiongMaitech на современном чипе Hi3516CV300 с модулем аналитики. Поддерживает H264, H265, ONVIF, RTSP. Xeoma модуль без проблем находит, однако очень долго подключается. Затем 30 секунд выводит на экран Основной поток, потом 30 секунд выводит на экран Долнительный поток, а затем вырубается и пишет, что проблема с IP или портом. Таким образом модуль у меня так и не заработал... Пробовал отключать H265, отключать смарт-кодирование H265++ - не помогло.

Пятая камера: 2-мегапиксельная PTZ куполка Besder BES-XMP200 на процессоре XiongMaitech XM530AI. Так как проц доисторический, то камеру поддержиавет только H264, ONVIF, RTSP. Однако с ним те же самые проблемы, что и с предыдущим. Xeoma модуль без проблем находит, однако очень долго подключается. Затем 30 секунд выводит на экран Основной поток, потом 30 секунд выводит на экран Долнительный поток, а затем вырубается и пишет, что проблема с IP или портом. Таким образом модуль у меня так и не заработал.

По последним двум камерам самые большие проблемы на ровном месте. Вроде и бы RTSP распознаются в модуле управления Xeoma, но Xeoma что-то делает с модулями, что они отрубаются каждые 30 секунд. Я параллельно на ноутбуке подключался с помощью VLC на RTSP-поток видеокамер. Всё идёт без сучка и задоринки. Как только я при этом включаю Xeoma, через 30сек. поток на VLC отрубается...

В общем завтра в рабочее время буду мучать техническую поддержку по данным вопросам. Так как у меня есть белый IP, то смогу пробросить порты на роутере для прямого соединение технической поддержки с Xeoma. Хочу отдельно поблагодарить компанию, что она предусмотрела пробную версию программы, потому что если бы я словил такие глюки после покупки лицензии - было бы совсем грустно...
Отдельно хотелось бы коснуться аппаратного ускорения. Оказалось, что Xeoma поддерживает аппаратное ускорение только от Nvidia. Я же приобретал процессор с довольно мощным видеоядром AMD в надежде, что Xeoma будет использовать его потенциал при декодировании изображения. Однако увы... В итоге при выводе на экран изображение с трёх камер (два по основному потоку, одна по дополнительному) я получаю сообщение от Xeoma о том, что программа не успевает... И это при загрузке процессора на 40%.
Maikl
 
Posts: 1
Joined: Sun Sep 27, 2020 5:29 am

Return to Xeoma - форум программы

Who is online

Users browsing this forum: No registered users and 1 guest

cron